Bug 13466 - CU182 Testing - All virtualbox interfaces are gone after rebooting
Summary: CU182 Testing - All virtualbox interfaces are gone after rebooting
Alias: None
Product: IPFire
Classification: Unclassified
Component: --- (show other bugs)
Version: 2
Hardware: x86_64 Unspecified
: Will affect an average number of users Crash
Assignee: Arne.F
QA Contact:
Depends on:
Reported: 2023-12-06 13:34 UTC by Adolf Belka
Modified: 2024-01-24 11:28 UTC (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Adolf Belka 2023-12-06 13:34:24 UTC
Ran the CU182 Testing on 2 of my VirtualBox vm's.

The upgrade itself went okay but when rebooting all the virtual interfaces were gone and so none of red0, green0, blue0 or orange0 could be setup and dhcp therefore failed to start.

In case this was a hiccup of some sort, I repeated, creating a clone of CU181, which worked fine, and doing the update to CU182 and again after rebooting both of them had no interfaces available.
Comment 1 Adolf Belka 2023-12-06 13:36:39 UTC
I have just seen that someone else has reported a similar result but with proxmox and the virtio interfaces all being gone after update to CU182.

Comment 2 Michael Tremer 2023-12-06 14:42:29 UTC
Okay, this seems to be something very serious. Any ideas which commit could be the culprit?
Comment 3 Michael Tremer 2023-12-06 14:50:11 UTC
(In reply to Michael Tremer from comment #2)
> Okay, this seems to be something very serious. Any ideas which commit could
> be the culprit?

I believe this is because of this commit:

> https://git.ipfire.org/?p=ipfire-2.x.git;a=commitdiff;h=63ac685b9781a18642109696d19eda6fac249666

Peter manually removes all versions of liblzma which is required by modprobe and udev which doesn't start at all. Therefore the kernel does not load any modules and you don't have networking.

Arne is on it.
Comment 4 Adolf Belka 2023-12-06 15:10:18 UTC
Ah. That liblzma removal also impacted alsa. In fact that was the first thing that was flagged up on the forum.

At least several thnings that have been flagged up will get fixed by the update to the update.sh file.
Comment 5 Arne.F 2023-12-07 07:20:42 UTC
A missing liblzma renders pakfire not working so all packet installations fail and modprobe cannot read the xz compressed modules so the kernel may not works at all.

The update should now fixed and i have also added some firmware files to alsa now.
Please check if both works now.
Comment 6 Adolf Belka 2023-12-07 09:10:33 UTC
I can confirm that the update now works without any red failure messages and all interfaces are present and the vm's were able to reboot and show the WUI pages.

So that confirms that the fix works for me.

I don't have any sound system capability on my vm's so cannot test out the alsa fix.
However I have asked the person on the forum who originally flagged up the alsa issue with CU182 if they can do another update and confirm if everything works, also for the alsa part.
Comment 8 Adolf Belka 2024-01-24 11:28:25 UTC
No feedback was ever received from the person who originally mentioned the alsa issue so it has to be presumed that it was also fixed by this fix.