Bug 12615 - OVPN Roadwarrior statistics graph failed
Summary: OVPN Roadwarrior statistics graph failed
Status: CLOSED FIXED
Alias: None
Product: IPFire
Classification: Unclassified
Component: --- (show other bugs)
Version: 2
Hardware: x86_64 Unspecified
: - Unknown - Aesthetic Issue
Assignee: Leo H
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-07 10:04 UTC by Silvio
Modified: 2021-06-21 20:47 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silvio 2021-05-07 10:04:56 UTC
Since the 156 update the statistics graph for OVPN Roadwarrior users failed.
The message  is "URL parameters missing or malformed":
It looks like a problem (in my case) with the name of the generated statistics dir for the ovpn user.
The collectd process creates a dir bases with the name based on the "Remarks" field of the ovpn user. This field is filled up with the name of the users separated by spaces. 
If i delete the space in the dirname the graph will be shown but not updated by collectd.
Eventually it's better to use the "name" field from the ovpn users page to create the dirs because this field allows no spaces or "special" characters.

Silvio
Comment 1 Michael Tremer 2021-05-07 10:05:43 UTC
@Leo: Would this be one for you?
Comment 2 Leo H 2021-05-07 15:06:07 UTC
(In reply to Michael Tremer from comment #1)
> @Leo: Would this be one for you?

Yes, this is probably due to my parameter checking. I used quite strict regular expressions, because I did not expect that someone would put spaces in the graph parameters. I'll take a look at it.
Comment 3 Silvio 2021-05-07 15:18:12 UTC
Hello Leo,

it was not my goal to put spaces in the parameters.
I see additional problems with the usage of the "remarks" field because i'm not sure if this field is unique.


Silvio
Comment 4 Leo H 2021-05-08 12:31:01 UTC
Hi Silvio,

sorry, I did not make that clear. You (the user) should of course be able to put spaces in the "remarks" field without worrying about it! I expected OVPN to generate sanitized parameters from the input.

On my test system, OVPN uses the subject CN ("User's full name or system hostname") field of the SSL certificate in the collectd path. I could not get it to use the "remarks" field.
This is good because SSL ensures that the "subject" field is unique.

I'll submit a patch to allow more non-word characters in the graph URL.

Unfortunately, the ovpnmain.cgi is very complicated. I don't think I'll be able to change the underlying issue without breaking more stuff.
But I agree that using the "name" field would be the way to go.

Leo
Comment 5 Peter Müller 2021-05-14 07:15:10 UTC
https://patchwork.ipfire.org/patch/4265/
Comment 6 Adolf Belka 2021-05-18 21:20:17 UTC
*** Bug 12624 has been marked as a duplicate of this bug. ***
Comment 7 Silvio 2021-06-21 20:40:03 UTC
Fixed in IPFire Release 157